Clarkston Campus Inbound Call Issue

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 10:13 EST

Monitoring

A fix has been applied, and inbound calls are being successfully delivered and answered. We will continue to monitor this issue.
Posted Jan 06, 2026 - 15:10 EST

Investigating

IIT is currently investigating reports of external inbound call issues to Clarkston Direct numbers (678-891-3XXX). GSU Clarkston phones remain fully functional for internal and outbound calls. The service provider has been engaged and updates will be provided as more information becomes available.
Posted Jan 06, 2026 - 13:58 EST
This incident affected: Telephone System.