CampusID PW Sync Issue to Microsoft O365

Incident Report for GSU Technology Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 10:49 EDT

Investigating

Instructional Innovation and Technology (IIT) is currently investigating an issue with CampusID password synchronization to Microsoft O365. If you have recently updated your password and are unable to access your email using the new credentials, please try logging in with your previous password. Updates will be provided as more information becomes available.
Posted Jul 31, 2025 - 11:16 EDT
This incident affects: Office 365 (Fac/Staff Email).