GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
This GSU website incident has been resolved. Please contact IIT Technology Service Desk to report any additional issue at 404-413-4357(help) or email help@gsu.edu.
Posted 15 days ago. Sep 06, 2019 - 17:49 EDT
Identified
Instructional Innovation and Technology (IIT) is currently investigating and have identified the issue with GSU Websites. Additional information will be posted here when the issue is confirmed.
Posted 15 days ago. Sep 06, 2019 - 16:41 EDT
This incident affected: University Website.