Dunwoody Campus - Power Outage

Incident Report for GSU Technology Systems

Monitoring

The Dunwoody Campus power outage is resolved. Please submit a new incident to IIT Technology Service Desk at help@gsu.edu, help.gsu.edu or call 404-413-4357(help) if there are any new network related issues to report.
Posted May 07, 2026 - 11:56 EDT

Update

The Dunwoody Campus power outage is resolved. Please submit a new incident to IIT Technology Service Desk at help@gsu.edu, help.gsu.edu or call 404-413-4357(help) if there are any new network related issues to report.
Posted May 07, 2026 - 11:50 EDT

Identified

A utility power outage is currently affecting the entire Dunwoody campus.

Further updates will be provided as more information becomes available.
Posted May 07, 2026 - 10:32 EDT
This incident affects: Campus Network and Campus Wireless Network.