Newton Campus Network

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 12:42 EST

Monitoring

Newton Campus network is back online, and we are monitoring stability.
Posted Dec 13, 2025 - 14:03 EST

Investigating

We are currently investigating multiple network devices being unreachable at the Newton Campus.

Network Services staff is actively working to determine the cause and determine eta on restoral of service.

Updates will be provided as more information becomes available.
Posted Dec 13, 2025 - 08:36 EST
This incident affected: Campus Network.