Office 365 (Fac/Staff Email) Issues Reported
Incident Report for GSU Technology Systems
Resolved
All Faculty/Staff and Non-person(Department) email accounts should be accessible now and the issue has been resolved.

Users may have to clear the internet browser history or remove and re-add your Outlook profiles in order for mailboxes to be accessible.

How to Clear Internet Browser History/Cache:
https://gsutech.service-now.com/sp?sys_kb_id=3823acd6db452f402c5b9696db9619f4&id=kb_article_view&sysparm_rank=1&sysparm_tsqueryId=a4c0fe6393310a503174f9d56aba1099

How to access Non-Person(Department) Account:
https://gsutech.service-now.com/sp?id=kb_article&sys_id=01ca7369db389740186e5058dc961957

Please report any new incidents to IIT Technology Service Desk at the self-service portal of help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP) if you are still receive an error when accessing a non-person or Office 365 email account.
Posted May 03, 2024 - 13:25 EDT
Monitoring
All Faculty/Staff and Non-person(Department) email accounts should be accessible without receiving an error message. The issue has been resolved and we will continue to monitor this situation over the next 24 hours.

Users may have to clear the internet browser history or remove and re-add your Outlook profiles in order for mailboxes to be accessible.

How to Clear Internet Browser History/Cache:
https://gsutech.service-now.com/sp?sys_kb_id=3823acd6db452f402c5b9696db9619f4&id=kb_article_view&sysparm_rank=1&sysparm_tsqueryId=a4c0fe6393310a503174f9d56aba1099

How to access Non-Person(Department) Account:
https://gsutech.service-now.com/sp?id=kb_article&sys_id=01ca7369db389740186e5058dc961957

Please report any new incidents to IIT Technology Service Desk at the self-service portal of help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP) if you are still receive an error when accessing a non-person or Office 365 email account.
Posted May 02, 2024 - 10:12 EDT
Identified
The access issue reported with many Faculty/Staff email accounts has been identitfied and a fix was applied.

Faculty/Staff should now be able to access their emails successfully.

However, the non-person(departmental) email accounts that were affected by this outage are still a WIP.

Please continue to check status.gsu.edu for updates on this Office 365 issue as they become available.
Posted May 01, 2024 - 08:14 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with Office 365 (Fac/Staff Email). Some Faculty and Staff are unable to access their Office 365 email accounts.

Additional information will be posted here when the issue is confirmed.
Posted Apr 30, 2024 - 10:10 EDT
This incident affected: Office 365 (Fac/Staff Email).