Outlook Client Issues
Incident Report for GSU Technology Systems
Resolved
Outlook services are fully restored and issue resolved. Please contact IIT Technology Service Desk at 404-413-4357(help) or email help@gsu.edu to report any additional requests.
Posted 2 months ago. Jul 19, 2019 - 17:35 EDT
Monitoring
Microsoft Outlook environment is back online. Users should now be able to access Microsoft Outlook without any errors. If you are still having issues, please allow a few more mins to connect to Microsoft Exchange server successfully.
Posted 2 months ago. Jul 19, 2019 - 13:56 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating issues with being able to access emails via Outlook Client's and Mobile native clients. Updates will be provided as they become available. As a workaround, you can access GSU email via the web at outlook.com/gsu.edu.
Posted 2 months ago. Jul 19, 2019 - 10:18 EDT
This incident affected: Office 365 (Fac/Staff Email).