Service Disruption: GSU PD MAIN LINE

Incident Report for GSU Technology Systems

Resolved

The issue has been resolved.

To report any other related issues, please submit ticket either via help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP)
Posted Dec 15, 2025 - 12:35 EST

Update

Calls to 404-413-3333 have been temporarily rerouted to allow GSU PD to handle calls until the vendor restores the services.
Posted Dec 14, 2025 - 23:00 EST

Identified

An issue has been identified with calls to 404-413-3333 not ringing through to GSU PD.

We are investigating and will provide updates as they become available.
Posted Dec 14, 2025 - 20:10 EST
This incident affected: Telephone System.