Network Outage: Decatur Campus

Incident Report for GSU Technology Systems

Resolved

Network issues reported on the Decatur campus has been resolved.

If you still experience any network related problems while located on that campus, please report them to the IIT Technology Service Desk using the self-service portal help.gsu.edu, email help@gsu.edu or call 404-413-4357(HELP).
Posted Aug 19, 2025 - 10:12 EDT

Investigating

We are currently investigating network issues at our Decatur campus.

If you experience any related problems, please report them to the IIT Technology Service Desk using the self-service portal help.gsu.edu, email help@gsu.edu or call 404-413-4357(HELP).
Posted Aug 19, 2025 - 09:09 EDT
This incident affected: Campus Network.