Power Outage: Dunwoody Campus

Incident Report for GSU Technology Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2026 - 22:43 EST

Investigating

The Dunwoody Campus is currently experiencing a power outage, which is impacting network services.
Posted Jan 25, 2026 - 15:54 EST
This incident affects: Campus Network.