Decatur Campus - Phone Issue

Incident Report for GSU Technology Systems

Resolved

External inbound call issues to Decatur Direct numbers (678-891-2000) has been resolved.

Please report any new incidents to help.gsu.edu, help@gsu.edu or call 404-413-4357(help)z
Posted Jan 21, 2026 - 19:51 EST

Investigating

IIT is currently investigating reports of external inbound call issues to Decatur Direct numbers (678-891-2000). GSU Decatur phones remain fully functional for internal and outbound calls. The service provider has been engaged and updates will be provided as more information becomes available.
Posted Jan 21, 2026 - 11:40 EST
This incident affected: Telephone System.