Spectrum Services Issues Reported

Incident Report for GSU Technology Systems

Resolved

Access to Spectrum has been restored. While successfully connected to Cisco VPN, please attempt to access Spectrum Services again.

Please report any new Spectrum related issues to help.gsu.edu, help@gsu.edu or 404-413-4357(HELP).
Posted Aug 18, 2025 - 13:52 EDT

Identified

Instructional Innovation and Technology (IIT) is currently investigating and has identified the cause of the log-on issues onto the Spectrum Services.

Additional information will be posted here on status.gsu.edu when the issue has been resolved.
Posted Aug 18, 2025 - 07:04 EDT
This incident affected: Spectrum Services.