iCollege Email Delays
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 09:43 EDT
Monitoring
D2L has confirmed the full functionality of iCollege Email has been restored. We will continue to monitor this system for stability.
Posted Oct 01, 2020 - 19:16 EDT
Investigating
D2L, the vendor who provides iCollege, is investigating an issue that may impact email within iCollege. Sending of emails may be delayed at this time.

We will update you with additional information as it becomes available.
Posted Oct 01, 2020 - 17:30 EDT
This incident affected: Brightspace/iCollege.