Please submit a new incident to the portal at help.gsu.edu, email help@gsu.edu or call 404-413-4357(help) if there are any new network related issues to report.
Posted Apr 01, 2026 - 07:44 EDT
Monitoring
The Newton Campus network has been restored and we will continue to monitor the situation.
Please submit a new incident to the portal help.gsu.edu, email help@gsu.edu or call 404-413-4357(help) if the network issue still persists.
Posted Mar 31, 2026 - 17:41 EDT
Identified
The vendor has confirmed that the service disruption is the result of a fiber cut in the area. Repair efforts to restore service is in progress.
Posted Mar 31, 2026 - 14:01 EDT
Update
The vendor is engaged and is continuing to investigate this issue. More updates will be provided as the vendor works toward service restoration.
Posted Mar 31, 2026 - 11:55 EDT
Update
We are continuing to investigate this issue.
Posted Mar 31, 2026 - 11:09 EDT
Investigating
IIT is currently investigating network issues affecting the Newton Campus.
Updates will be provided as progress is made toward service resolution.