VoiceThread
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted May 28, 2020 - 09:07 EDT
Investigating
VoiceThread is investigating an issue that is causing errors when loading the tool. We will update you as we learn more from the vendor.
Posted Apr 02, 2020 - 15:04 EDT
This incident affected: VoiceThread.