Kivuto Software Website Access Issue
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) resolved issues with accessing the Kivuto (gsu.onthehub.com) software website. If you continue to experience issues, please contact the Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted 3 months ago. Jul 05, 2019 - 10:11 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating issues with accessing the Kivuto (gsu.onthehub.com) software website. We have contacted the vendor who is working on a solution. Updates will be posted as they become available.
Posted 3 months ago. Jul 03, 2019 - 15:11 EDT
This incident affected: Kivuto.