iCollege Login Page
Incident Report for GSU Technology Systems
Resolved
The issues with the iCollege login page have been resolved.
Posted Nov 02, 2020 - 11:52 EST
Investigating
Due to the current issues with the GSU website, please note that icollege.gsu.edu may experience issues. Please login via https://gastate.view.usg.edu for the best experience at this time.
Posted Oct 31, 2020 - 06:49 EDT
Monitoring
IIT has implemented a fix. GSU websites including icollege.gsu.edu are operable, and we will continue to monitor over the course of the day. If you continue to have problems accessing icollege.gsu.edu, please login via https://gastate.view.usg.edu.

If you continue to experience issues, please contact the IIT Technology Service Desk at help@gsu.edu.
Posted Oct 20, 2020 - 09:11 EDT
Investigating
Due to the current issues with the GSU website, please note that icollege.gsu.edu may experience issues. Please login via https://gastate.view.usg.edu for the best experience at this time.
Posted Oct 19, 2020 - 20:12 EDT
This incident affected: Brightspace/iCollege.